summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 05:37:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 07:11:36 +0200
commit9b77803251969ce0bd44c9c0cf627faa425ecd1c (patch)
treed7acc7b39475d612d83d72407295df362aed2644 /dev-python/ini2toml
parentdev-python/pytest-mock: Bump to 3.8.1 (diff)
downloadgentoo-9b77803251969ce0bd44c9c0cf627faa425ecd1c.tar.gz
gentoo-9b77803251969ce0bd44c9c0cf627faa425ecd1c.tar.bz2
gentoo-9b77803251969ce0bd44c9c0cf627faa425ecd1c.zip
dev-python/ini2toml: Bump to 0.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest1
-rw-r--r--dev-python/ini2toml/ini2toml-0.11.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index 9fa4a3fcb1f6..a307283e1b3b 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1 +1,2 @@
DIST ini2toml-0.10.gh.tar.gz 93535 BLAKE2B 8d8a5b31c53b9194e578b473dfd562b1b569d701b36b267ec4f59ea75ec03abd6e1df5541327b9414a2f1c04b1cb41ec57c6f900007f69a3c51a172143d2eacd SHA512 3d88f97c50a13fe3878e3fa35d70c9051874bec99d278411dcc7098d86898deb0e490be26f293e9a304d4c9a2842274e68126a2d20dac77b526161fde682dd75
+DIST ini2toml-0.11.gh.tar.gz 93696 BLAKE2B 0fb52b346065421049fd377a62de4189a6d261ad12c00679c97568a0e7b7f8fc7bf1aae2196b8fc70489d547c0ce9be1347336d25769c7fb383f9fec4d4aa205 SHA512 7329fd3ba31567638fffce22f2370c2055503bd4abc3d7dab30b1828eb54204d31036753efddfab52e79703ce7583f6070e1207c95345096c0751c2d429fd6ea
diff --git a/dev-python/ini2toml/ini2toml-0.11.ebuild b/dev-python/ini2toml/ini2toml-0.11.ebuild
new file mode 100644
index 000000000000..de5aad955494
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.11.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+SRC_URI="
+ https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # pyproject_fmt is not packaged
+ tests/test_cli.py::test_auto_formatting
+
+ # fails on whitespace/comments/formatting
+ tests/test_translator.py::test_simple_example
+ tests/test_translator.py::test_parser_opts
+ tests/plugins/test_setuptools_pep621.py::test_move_entry_points_and_apply_value_processing
+ tests/plugins/test_setuptools_pep621.py::test_split_subtables
+ tests/plugins/test_setuptools_pep621.py::test_entrypoints_and_split_subtables
+ tests/plugins/test_setuptools_pep621.py::test_handle_dynamic
+)
+
+EPYTEST_IGNORE=(
+ # configupdater is not packaged
+ tests/test_examples.py
+ tests/test_transformations.py
+ tests/drivers/test_configupdater.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}