summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-20 19:33:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-20 19:33:42 +0100
commitc3440c460e3ab31560b6d562610df8069f957f8d (patch)
tree67fe8f07871590ecf260bc014791cd454b9813ce /dev-python/installer
parentdev-python/cython: Remove old (diff)
downloadgentoo-c3440c460e3ab31560b6d562610df8069f957f8d.tar.gz
gentoo-c3440c460e3ab31560b6d562610df8069f957f8d.tar.bz2
gentoo-c3440c460e3ab31560b6d562610df8069f957f8d.zip
dev-python/installer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/installer')
-rw-r--r--dev-python/installer/Manifest2
-rw-r--r--dev-python/installer/installer-0.4.0_p20220124.ebuild52
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
index c3a388cfad95..615052a2d874 100644
--- a/dev-python/installer/Manifest
+++ b/dev-python/installer/Manifest
@@ -1,4 +1,2 @@
-DIST installer-0.4.0-py2.py3-none-any.whl.zip 451433 BLAKE2B 933b7e63b3d0306213789d493d4df112df26b432d63ecd1f8f21449520c34bd2ad542aac25069043fbb535c44f988dca927625eafd0a5a20489fc3ce2bcf84a2 SHA512 cf303bb422e329a36007b361034144a232ba021d4013bb8678dc7c326544e74ec9a3b3fe8b9d3696433dbbe90d2ce4a0ae8967fb054bd5ed49321d470be729a8
-DIST installer-0.4.0_p20220124.gh.tar.gz 468296 BLAKE2B 44763fd05b9e3cc665871817f3a6a417ddc12274ae42989e96ad432af98d42c23ab9f1c1cc37e17d4b9ce06ead7ef0c8227b2b10fe5744c899a9e3ea347e4e33 SHA512 b25fa910e8a7d9a2757af4694bf12a64c8731213a5682ab02bbe472229c99dd9190b1e7663a7632d61cbf0585006b2d4de62115c40f9b132be2c70672e23726d
DIST installer-0.5.0-py3-none-any.whl.zip 452177 BLAKE2B 41bb5929c1bc42afa1e09f366356aa441eb92d258da40421d7f46ceb466ee4604ed96fef0969dcd2fe28e8f4b06c741ac3108000f69ea42b6bb194890102ad71 SHA512 470c4fec8888114af6769db8b8cefa09a376bfcdf0d78320f884a7453a4991765cdf0b9122c74d8e147d193e75ab3e12cc24c3b93c0668956c17f52443833c4e
DIST installer-0.5.0.gh.tar.gz 468351 BLAKE2B 6c258bdaae3351e87a88675fb813bb70611d9188ba16a09ba03de4caa3d79fe32544e229f880338304d00343c2b3121b1948bbef2e27c7255d231a3d5665aa5f SHA512 8731bbf8a51b1094dc87f84575eec07a650988bdeddf205d04cf80a5088eac0d8b2927022864f4011a9562fcaae9f511747e5672f94ec3cce1dccdfa833c4fce
diff --git a/dev-python/installer/installer-0.4.0_p20220124.ebuild b/dev-python/installer/installer-0.4.0_p20220124.ebuild
deleted file mode 100644
index 6dba1598032c..000000000000
--- a/dev-python/installer/installer-0.4.0_p20220124.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-EGIT_COMMIT="05855a926b2e6d9a1be6d567300883b7a6ff3ce7"
-DESCRIPTION="A library for installing Python wheels"
-HOMEPAGE="
- https://pypi.org/project/installer/
- https://github.com/pradyunsg/installer/
- https://installer.readthedocs.io/en/latest/
-"
-# TODO: switch back to pradyunsg/ upstream when the CLI PR is merged
-# https://github.com/pradyunsg/installer/pull/94
-SRC_URI="
- https://github.com/takluyver/installer/archive/${EGIT_COMMIT}.tar.gz
- -> ${P}.gh.tar.gz
- https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P%_p*}-py2.py3-none-any.whl
- -> ${P%_p*}-py2.py3-none-any.whl.zip
-"
-S=${WORKDIR}/${PN}-${EGIT_COMMIT}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# NB: newer git doesn't use mock anymore
-BDEPEND="
- app-arch/unzip
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-# do not use any build system to avoid circular deps
-python_compile() { :; }
-
-python_test() {
- local -x PYTHONPATH=src
- epytest
-}
-
-python_install() {
- python_domodule src/installer "${WORKDIR}"/*.dist-info
-}