summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-18 12:21:21 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 12:34:08 +0200
commit116b452abc7778d161327516f9229c8256ef2c18 (patch)
tree587ef9c70e0b81905e3ae0f8712ca6f9c848d7f8 /dev-python/iocapture/iocapture-0.1.2-r2.ebuild
parentdev-python/iocapture: Drop old (diff)
downloadgentoo-116b452abc7778d161327516f9229c8256ef2c18.tar.gz
gentoo-116b452abc7778d161327516f9229c8256ef2c18.tar.bz2
gentoo-116b452abc7778d161327516f9229c8256ef2c18.zip
dev-python/iocapture: EAPI=7, Py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iocapture/iocapture-0.1.2-r2.ebuild')
-rw-r--r--dev-python/iocapture/iocapture-0.1.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2-r2.ebuild b/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..d25890b6cb65
--- /dev/null
+++ b/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture stdout, stderr easily"
+HOMEPAGE="https://pypi.org/project/iocapture/"
+SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}