summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 14:02:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 14:02:29 -0700
commit5ada30758282bd5e2c25d52d8f9b691e4543e006 (patch)
treea33fd0672ef7be7e4dc345fe64bf14981003954f /dev-python/ioflo/ioflo-2.0.0.ebuild
parentdev-python/ioflo-1.7.8: Version bump (diff)
downloadgentoo-5ada30758282bd5e2c25d52d8f9b691e4543e006.tar.gz
gentoo-5ada30758282bd5e2c25d52d8f9b691e4543e006.tar.bz2
gentoo-5ada30758282bd5e2c25d52d8f9b691e4543e006.zip
dev-python/ioflo-2.0.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ioflo/ioflo-2.0.0.ebuild')
-rw-r--r--dev-python/ioflo/ioflo-2.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ioflo/ioflo-2.0.0.ebuild b/dev-python/ioflo/ioflo-2.0.0.ebuild
new file mode 100644
index 000000000000..f572567710fd
--- /dev/null
+++ b/dev-python/ioflo/ioflo-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7,8})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-lang/python-3.7.4' python3_7)
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/ioflo-1.7.8-network-test.patch"
+)
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}