summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-01-05 08:50:01 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-01-05 08:50:01 +0100
commitbc363dd82c44bca3c9e13089d917aba5c0c6c995 (patch)
tree6e108bae5786aa8cfefb5f7ba6eee003a90b478b /dev-python/ipykernel/ipykernel-4.2.2.ebuild
parentdev-ruby/will_paginate: add 3.1.0 (diff)
downloadgentoo-bc363dd82c44bca3c9e13089d917aba5c0c6c995.tar.gz
gentoo-bc363dd82c44bca3c9e13089d917aba5c0c6c995.tar.bz2
gentoo-bc363dd82c44bca3c9e13089d917aba5c0c6c995.zip
dev-python/ipykernel: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/ipykernel/ipykernel-4.2.2.ebuild')
-rw-r--r--dev-python/ipykernel/ipykernel-4.2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ipykernel/ipykernel-4.2.2.ebuild b/dev-python/ipykernel/ipykernel-4.2.2.ebuild
new file mode 100644
index 000000000000..ac4257b18600
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-4.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --verbose ipykernel || die
+}