summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 10:37:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 11:11:48 +0200
commite622261cd695b4ddbcb5f61f35c7e5aa68686eb7 (patch)
treeae2d3f97faae552273bb28b7638d0f4a561150c8 /dev-python/ipykernel/ipykernel-5.3.4-r1.ebuild
parentdev-python/ipyparallel: Remove py36 in new rev due to ipython (diff)
downloadgentoo-e622261cd695b4ddbcb5f61f35c7e5aa68686eb7.tar.gz
gentoo-e622261cd695b4ddbcb5f61f35c7e5aa68686eb7.tar.bz2
gentoo-e622261cd695b4ddbcb5f61f35c7e5aa68686eb7.zip
dev-python/ipykernel: Remove py36 in new rev due to ipython
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipykernel/ipykernel-5.3.4-r1.ebuild')
-rw-r--r--dev-python/ipykernel/ipykernel-5.3.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ipykernel/ipykernel-5.3.4-r1.ebuild b/dev-python/ipykernel/ipykernel-5.3.4-r1.ebuild
new file mode 100644
index 000000000000..d8754af6f7c2
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-5.3.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ipython-6[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest