summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-14 04:45:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-14 06:26:12 +0200
commitc7ce3e711da7ac07f3d85340dcfa2da3539a511c (patch)
tree011c06215aefeb11eff23d354be14af16a6e293f /dev-python/ipykernel
parentdev-python/PyPDF2: Bump to 2.2.0 (diff)
downloadgentoo-c7ce3e711da7ac07f3d85340dcfa2da3539a511c.tar.gz
gentoo-c7ce3e711da7ac07f3d85340dcfa2da3539a511c.tar.bz2
gentoo-c7ce3e711da7ac07f3d85340dcfa2da3539a511c.zip
dev-python/ipykernel: Bump to 6.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.14.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 041922566777..dd3a080086ba 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,2 +1,3 @@
DIST ipykernel-6.13.0.tar.gz 131331 BLAKE2B 95a662b5ff6062fd8f6712a214b2bdcb227064acec145ebbb2ff7dfc0647ee9c486bbb560502e8ab6c5f74bb44c7715a1ee16f4b8cd2661b7a6e77206be7ab67 SHA512 6025a540d7ae08f637d2cc9a022805df54c11844c93d989be73a3a800fb0985ec56f2ce5d8ee940a5ce51d41b4d1f632131b25c1f5847cb51623c285c4944f39
DIST ipykernel-6.13.1.tar.gz 134356 BLAKE2B 212449f5e49f05052e36b60abc94ccfd81dcf6c13948d2ba32373ffab59f009ac28c251f6b9a9f5412b3d9a0f1347a2352f2e61b831d5efd8d45663ca43b4fdf SHA512 be0f5cf4eab8cf38f20a96e6e59971988bfc03105525694787d4dbbd092e22efb5b955ef622e0c8bc87fb43f29b0f4dc8affa89b81cd2eb7b4d9c93f7b9c68e5
+DIST ipykernel-6.14.0.tar.gz 134614 BLAKE2B 41c2d9179aae12aad207ff76f1451dd42beb4fa12123146a7ccbde2aaf12b52f374bd8d4e7c88bc26fed6e7a5b06629ce1e91ba87cf61e16d3de1bbd50edfac9 SHA512 cecefaf7221a640c5066b5bf77cb21750ddac78262aba6e0449e42f3db124624f87d88fe44351c6943753ee08d7b9a3780bcbb84dc7338e8e26d15c3ad6b1eea
diff --git a/dev-python/ipykernel/ipykernel-6.14.0.ebuild b/dev-python/ipykernel/ipykernel-6.14.0.ebuild
new file mode 100644
index 000000000000..06e969aa4a9d
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.14.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/debugpy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-6.1.12[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ ipykernel/inprocess/tests/test_kernel.py::InProcessKernelTestCase::test_pylab
+ ipykernel/tests/test_debugger.py::test_attach_debug
+ ipykernel/tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
+ ipykernel/tests/test_debugger.py::test_rich_inspect_at_breakpoint
+ ipykernel/tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ ipykernel/tests/test_debugger.py::test_set_breakpoints
+ ipykernel/tests/test_debugger.py::test_stop_on_breakpoint
+)
+
+src_prepare() {
+ sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Use python3 in kernel.json configuration, bug #784764
+ sed -i -e '/python3.[0-9]\+/s//python3/' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
+}