summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 17:11:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 17:29:24 +0100
commit6f8f89b2a5d064ac2c74302d997bd2ab632a2367 (patch)
tree9f4d3bb27cfbd1b5270203141b66dd666c6ba877 /dev-python/ipyparallel
parentdev-python/ipykernel: Remove redundant versions (diff)
downloadgentoo-6f8f89b2a5d064ac2c74302d997bd2ab632a2367.tar.gz
gentoo-6f8f89b2a5d064ac2c74302d997bd2ab632a2367.tar.bz2
gentoo-6f8f89b2a5d064ac2c74302d997bd2ab632a2367.zip
dev-python/ipyparallel: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 229e61c6a6e6..261ff3c93b1c 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,2 +1 @@
-DIST ipyparallel-6.0.2.tar.gz 2366627 BLAKE2B 333d6043c1e3635a37ebd464a5eb6bd0d21d0815abf106f8a7dd138128790d89ccb856dd981c281ce023cded589e6352fd6cd48efab61c8955abfbfea157eb35 SHA512 2dab781eac81bb3c2d4eedff9689448ed8d4317b47a1e8110a0b16147f986428f6fefe13acd12ee8604ec7775aee46a5f62c7d6a676bda7f8d3d39d95d90f28d
DIST ipyparallel-6.2.3.tar.gz 2371030 BLAKE2B 73f96bbed280def33ae243e592ecf2e298afe92287cf3a7edb966859c38c6dcb1f1a43082ab83907aa00e06d571f4b750df28e6885a1c2d1fd1489fd4472a7fc SHA512 ddf479a7776c2ca9fd37aa5b7dd402c136ce62a479333f5f56dce413649f9b928daed56c173ad5325268eaa58667d611257b20c8269899cc06ae2829f973b4c1
diff --git a/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild b/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild
deleted file mode 100644
index e278f8a4abc2..000000000000
--- a/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Interactive Parallel Computing with IPython"
-HOMEPAGE="https://ipyparallel.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- !<dev-python/ipython-4.0.0[smp,${PYTHON_USEDEP}]
- >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- iptest --coverage xml ipyparallel.tests -- -vsx || die
-}