summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-15 16:55:48 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:28:30 +0000
commit33174f2c547c9561246fe41c1740175db690467d (patch)
treede1c4858ca64add3df46ec8ca9332332bd22db50 /dev-python/ipython
parentdev-python/prompt_toolkit: version bump (diff)
downloadgentoo-33174f2c547c9561246fe41c1740175db690467d.tar.gz
gentoo-33174f2c547c9561246fe41c1740175db690467d.tar.bz2
gentoo-33174f2c547c9561246fe41c1740175db690467d.zip
dev-python/ipython: version bump, python-3* only
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest1
-rw-r--r--dev-python/ipython/ipython-6.1.0.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index d0d26013f90a..8b964d8dafb3 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,3 +1,4 @@
DIST ipython-3.2.1.tar.gz 10884249 SHA256 c913adee7ae5b338055274c51a7d2b3cea468b5b316046fa520cd8a434b09177 SHA512 de7723e3b859d21a58a24456c76c8d8ec98c019f290f61269f46270e7647d2b49a98671138fecd75cb6f46384fde7e09618eb5c85c175e0e442c7fae7328d8fe WHIRLPOOL 9f020c167559259931dcb177d0c3a5211939632e5775c2627795ba390cf57bd62c378c15b7ee9b9ed2079180f8df8e062eb9673ed9cfc025a56f1da82c9428d1
DIST ipython-5.3.0.tar.gz 4967956 SHA256 bf5e615e7d96dac5a61fbf98d9e2926d98aa55582681bea7e9382992a3f43c1d SHA512 41706d7521cc84f36f5580dc44cd91832a60aa8a7a946d15a9ec9563649b9ae97931b9f135f1fdbaecbcb0b9b925d467edfd6eec7f8c82309872047be77b598d WHIRLPOOL 96478b15fd4928d11da35dbbaba6492ff12cf739c06b6f9cf8fdd827060baf5c07d093c3e340792b62102f85ada0b6ea29adc742b784ad21e5292cde09a6fa25
DIST ipython-5.4.1.tar.gz 4973571 SHA256 afaa92343c20cf4296728161521d84f606d8817f963beaf7198e63dfede897fb SHA512 b37dae27a558585ec4f42fa22e86380ac81990207ec680fc7b0e6f97ac81c99d915cfe77488bc0b91a61c34e0c00b323df08aa06b142ce0fc88ce30203102907 WHIRLPOOL e91e719a681c29e8ecd3e08ade470adcefb957ffddfa601f89306c19b6f6e80fa793a603948fb9fd697884474f2559ece30456be27d9034448cb618217a8cfa1
+DIST ipython-6.1.0.tar.gz 5066094 SHA256 5c53e8ee4d4bec27879982b9f3b4aa2d6e3cfd7b26782d250fa117f85bb29814 SHA512 6b1d9713b5e8c3870ac8cd8bea9d3a6f0c0302e3983017516128ede9f0baba21372890873df29fbba3f9d2f47ba16bfadb1c611f9de23b71595c0ab8f917695b WHIRLPOOL 9b579922060a1d37487bb294314fae4ac19c8d98509c856c117c17f6eb8d617cd29b7d7fa5e44bb2b1004a70f893b0e83571f69149729b6f6ebcbaa162f257fa
diff --git a/dev-python/ipython/ipython-6.1.0.ebuild b/dev-python/ipython/ipython-6.1.0.ebuild
new file mode 100644
index 000000000000..612a99813dc4
--- /dev/null
+++ b/dev-python/ipython/ipython-6.1.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE='readline,sqlite,threads(+)'
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Advanced interactive shell for Python"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples matplotlib notebook nbconvert qt4 qt5 +smp test"
+
+CDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-1.0.4[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${CDEPEND}
+ notebook? (
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ )
+ nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )
+"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/typing[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
+ )
+"
+
+PDEPEND="
+ qt4? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ smp? ( dev-python/ipyparallel[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
+
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Remove out of date insource files
+ rm IPython/extensions/cythonmagic.py || die
+ rm IPython/extensions/rmagic.py || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html_noapi
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ pushd "${TEST_DIR}" >/dev/null || die
+ "${TEST_DIR}"/scripts/iptest || die
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "sympyprinting" dev-python/sympy
+ optfeature "cythonmagic" dev-python/cython
+ optfeature "%lprun magic command" dev-python/line_profiler
+ optfeature "%mprun magic command" dev-python/memory_profiler
+
+ if use nbconvert; then
+ if ! has_version app-text/pandoc ; then
+ einfo "Node.js will be used to convert notebooks to other formats"
+ einfo "like HTML. Support for that is still experimental. If you"
+ einfo "encounter any problems, please use app-text/pandoc instead."
+ fi
+ fi
+}