summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 17:48:42 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 17:48:42 +0200
commit664e0d0f43e4f3ddc8033a3b6a3d6d57d0590425 (patch)
tree0811571a9ea230e8d9545465b957b1570389a289 /dev-python/ipython
parentdev-python/pillow: Do not require anything unconditionally (diff)
downloadgentoo-664e0d0f43e4f3ddc8033a3b6a3d6d57d0590425.tar.gz
gentoo-664e0d0f43e4f3ddc8033a3b6a3d6d57d0590425.tar.bz2
gentoo-664e0d0f43e4f3ddc8033a3b6a3d6d57d0590425.zip
dev-python/ipython: Drop vulnerable version (CVE-2015-5607, CVE-2015-7337)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=554868 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=560708 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest1
-rw-r--r--dev-python/ipython/files/2.1.0-disable-tests.patch32
-rw-r--r--dev-python/ipython/ipython-2.2.0-r1.ebuild137
3 files changed, 0 insertions, 170 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index a7ca2e24d4c8..49d8b3fe82d9 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,2 +1 @@
-DIST ipython-2.2.0.tar.gz 11912007 SHA256 b7ca77ba54a02f032055b73f5f62b01431f818ae00f63716b78f881c2b2564e2 SHA512 4953bf5e9d6d5c6ad538d07d62b5b100fd86a37f6b861238501581c0059bd4655345ca05cf395e79709c38ce4cb9c6293f5d11ac0252a618ad8272b161140d13 WHIRLPOOL a5e433a3a840b65fd0644f023cc9e93862e48a906e4e9d1596ebbd24290d486be580dca017ef1586da980b6792dcd7ed9aab4af81421bbf083d885927db6fcc8
DIST ipython-3.2.1.tar.gz 10884249 SHA256 c913adee7ae5b338055274c51a7d2b3cea468b5b316046fa520cd8a434b09177 SHA512 de7723e3b859d21a58a24456c76c8d8ec98c019f290f61269f46270e7647d2b49a98671138fecd75cb6f46384fde7e09618eb5c85c175e0e442c7fae7328d8fe WHIRLPOOL 9f020c167559259931dcb177d0c3a5211939632e5775c2627795ba390cf57bd62c378c15b7ee9b9ed2079180f8df8e062eb9673ed9cfc025a56f1da82c9428d1
diff --git a/dev-python/ipython/files/2.1.0-disable-tests.patch b/dev-python/ipython/files/2.1.0-disable-tests.patch
deleted file mode 100644
index bdbb1be4246e..000000000000
--- a/dev-python/ipython/files/2.1.0-disable-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-The extension magics for oct2py and rpy live now in the oct2py and rpy2 package. The tests shipped with ipython are broken. We should disable
-those tests and remove the magics files:
-
-IPython/extensions/rmagic.py -> rpy/ipython/rmagic.py
-IPython/extension/octavemagic.py -> oct2py/ipython/octavemagic.py
-
-deleted: IPython/extensions/octavemagic.py
-deleted: IPython/extensions/rmagic.py
-modified: IPython/testing/iptest.py
-
-diff --git a/IPython/testing/iptest.py b/IPython/testing/iptest.py
-index 45d2c78..db0bdfe 100644
---- a/IPython/testing/iptest.py
-+++ b/IPython/testing/iptest.py
-@@ -250,12 +250,10 @@ sec = test_sections['extensions']
- if not have['cython']:
- sec.exclude('cythonmagic')
- sec.exclude('tests.test_cythonmagic')
--if not have['oct2py']:
-- sec.exclude('octavemagic')
-- sec.exclude('tests.test_octavemagic')
--if not have['rpy2'] or not have['numpy']:
-- sec.exclude('rmagic')
-- sec.exclude('tests.test_rmagic')
-+sec.exclude('octavemagic')
-+sec.exclude('tests.test_octavemagic')
-+sec.exclude('rmagic')
-+sec.exclude('tests.test_rmagic')
- # autoreload does some strange stuff, so move it to its own test section
- sec.exclude('autoreload')
- sec.exclude('tests.test_autoreload')
-
diff --git a/dev-python/ipython/ipython-2.2.0-r1.ebuild b/dev-python/ipython/ipython-2.2.0-r1.ebuild
deleted file mode 100644
index 62c6f8e16c4f..000000000000
--- a/dev-python/ipython/ipython-2.2.0-r1.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-PYTHON_REQ_USE='readline,sqlite'
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Advanced interactive shell for Python"
-HOMEPAGE="http://ipython.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-IUSE="doc examples matplotlib mongodb notebook nbconvert octave qt4 +smp test wxwidgets"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-CDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/simplegeneric[${PYTHON_USEDEP}]
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
- mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
- octave? ( dev-python/oct2py[${PYTHON_USEDEP}] )
- smp? ( >=dev-python/pyzmq-2.1.11[${PYTHON_USEDEP}] )
- wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' python2_7) )"
-RDEPEND="${CDEPEND}
- notebook? (
- >=www-servers/tornado-3.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-2.1.11[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-libs/mathjax
- )
- nbconvert? (
- >=app-text/pandoc-1.12.1
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- )
- qt4? (
- || (
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-python/pyside[${PYTHON_USEDEP}]
- )
- dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-2.1.11[${PYTHON_USEDEP}] )"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PY2_USEDEP}]
- )
- doc? (
- dev-python/cython[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/fabric[${PYTHON_USEDEP}]' python2_7)
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- dev-python/pymongo[${PYTHON_USEDEP}]
- dev-python/rpy[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=www-servers/tornado-3.1[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/2.1.0-substitute-files.patch
- "${FILESDIR}"/2.1.0-disable-tests.patch
- "${FILESDIR}"/${P}-login-backport.patch
- )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Remove out of date insource files
- rm IPython/extensions/rmagic.py || die
- rm IPython/extensions/octavemagic.py || die
-
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-src_test() {
- # virtualx has trouble with parallel runs.
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- distutils_install_for_testing
- local fail
- run_tests() {
- pushd ${TEST_DIR} > /dev/null
- "${PYTHON}" -m IPython.testing.iptestcontroller --all || fail=1
- popd > /dev/null
- }
- VIRTUALX_COMMAND=run_tests virtualmake
- [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
- use notebook && dosym /usr/share/mathjax $(python_get_sitedir)/IPython/html/static/mathjax
-
- # Create ipythonX.Y symlinks.
- # TODO:
- # 1. do we want them for pypy? No. pypy has no numpy
- # 2. handle it in the eclass instead (use _python_ln_rel).
- # With pypy not an option the dosym becomes unconditional
- dosym ../lib/python-exec/${EPYTHON}/ipython \
- /usr/bin/ipython${EPYTHON#python}
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "To enable sympyprinting, it's required to emerge sympy"
- elog "To enable cythonmagic, it's required to emerge cython"
-}