summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:00:47 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:00:47 +0100
commit27f416ef6105b15d6052c93e676df08c11ceb4c5 (patch)
treeaa25897137df712589a5b121bba6b1023cb86460 /dev-python/ipython_genutils/ipython_genutils-0.1.0.ebuild
parentMerge branch 'marbre-mendeleydesktop' (diff)
downloadgentoo-27f416ef6105b15d6052c93e676df08c11ceb4c5.tar.gz
gentoo-27f416ef6105b15d6052c93e676df08c11ceb4c5.tar.bz2
gentoo-27f416ef6105b15d6052c93e676df08c11ceb4c5.zip
dev-python/ipython_genutils: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/ipython_genutils/ipython_genutils-0.1.0.ebuild')
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.1.0.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.1.0.ebuild
new file mode 100644
index 000000000000..07d3b68e2de1
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
+}