summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-03-03 14:44:58 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-04 16:18:21 +0100
commit239126c6f9ca1a9e9d8716c5c620394dc6dfbbf7 (patch)
tree1ea3f6d405b5ec61ec2621bbb62352f3fceb6204 /dev-python/ipywidgets/ipywidgets-6.0.0.ebuild
parentdev-python/widgetsnbextension: Version bump to 2.0.0 (diff)
downloadgentoo-239126c6f9ca1a9e9d8716c5c620394dc6dfbbf7.tar.gz
gentoo-239126c6f9ca1a9e9d8716c5c620394dc6dfbbf7.tar.bz2
gentoo-239126c6f9ca1a9e9d8716c5c620394dc6dfbbf7.zip
dev-python/ipywidgets: Version bump to 6.0.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4106
Diffstat (limited to 'dev-python/ipywidgets/ipywidgets-6.0.0.ebuild')
-rw-r--r--dev-python/ipywidgets/ipywidgets-6.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-6.0.0.ebuild b/dev-python/ipywidgets/ipywidgets-6.0.0.ebuild
new file mode 100644
index 000000000000..d4fe164d713c
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-6.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
+}