summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-23 08:46:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-23 09:30:38 +0200
commitf47e565e3168ef325070496dea0c817eec4648af (patch)
tree637fa35c39c4be619877316ea585d027c7917cea /dev-python/isort/isort-5.11.4.ebuild
parentapp-editors/vscodium: add 1.74.2.22355 (diff)
downloadgentoo-f47e565e3168ef325070496dea0c817eec4648af.tar.gz
gentoo-f47e565e3168ef325070496dea0c817eec4648af.tar.bz2
gentoo-f47e565e3168ef325070496dea0c817eec4648af.zip
dev-python/isort: add 5.11.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/isort/isort-5.11.4.ebuild')
-rw-r--r--dev-python/isort/isort-5.11.4.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/isort/isort-5.11.4.ebuild b/dev-python/isort/isort-5.11.4.ebuild
new file mode 100644
index 000000000000..bd9a3933387a
--- /dev/null
+++ b/dev-python/isort/isort-5.11.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="
+ https://github.com/PyCQA/isort/
+ https://pypi.org/project/isort/
+"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle tomli
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+ # leftover toml import used to determine .toml support
+ sed -i -e 's:import toml:toml = True:' tests/unit/test_isort.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit
+}