summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-21 21:21:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-21 21:21:50 +0200
commitb477b0613daec4a0e21e218dff8a941471637569 (patch)
tree75550b568621ed6e73fcf23eece5830384bdbaf4 /dev-python/isort
parentmedia-sound/fapg: Stabilize 0.43 amd64, #784446 (diff)
downloadgentoo-b477b0613daec4a0e21e218dff8a941471637569.tar.gz
gentoo-b477b0613daec4a0e21e218dff8a941471637569.tar.bz2
gentoo-b477b0613daec4a0e21e218dff8a941471637569.zip
dev-python/isort: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest1
-rw-r--r--dev-python/isort/isort-5.7.0.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 1d915f1b1abe..4ecc0049f124 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,2 +1 @@
-DIST isort-5.7.0.tar.gz 169353 BLAKE2B bafd6a0ce81ed80a3c1ad53ce320361ef11bc01a78211ad13b7947aafddd4d9bb5a4fbf65ec01d4c90dce7ebd0a2e3b1c4dcad729b1e27b1dd2c5c90c802eecf SHA512 ae5ff56394f495f6bd86f7581e0f8a67264671553b344b9dc2c5ba0b37f483ae500ebba9882ff5c315b913a689901b17de2eac403e0b4240f913c9e1864bab9f
DIST isort-5.8.0.tar.gz 167927 BLAKE2B 59b9ee4e63e231026e25833ef8bc4a782ad7b30622d1f6b61fe177fbf0f8663ca953f68cf168abb407d3cb90fe98e29540ec3a8933a5df2ca7ba3e938ba4282f SHA512 ffeee045b5328fa410673464b2ca22d9cd1ba8dd34eff9a430b93e9ce72033100e32e3373308438bcb82b8eb7deea1f2087091e111b1204e35791958ca6944c4
diff --git a/dev-python/isort/isort-5.7.0.ebuild b/dev-python/isort/isort-5.7.0.ebuild
deleted file mode 100644
index 5476eecba44a..000000000000
--- a/dev-python/isort/isort-5.7.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A python utility/library to sort imports"
-HOMEPAGE="https://pypi.org/project/isort/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-BDEPEND="
- test? (
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pylama[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Some tests run the "isort" command
- distutils_install_for_testing --via-root
-
- local skipped_tests=(
- # Fails without -s, run it separately to avoid unnecessary output
- tests/unit/test_importable.py
- # Excluded from upstream's test script
- tests/unit/test_deprecated_finders.py
- # Require "example_isort_formatting_plugin", we're not going
- # to add an example package just to run a few tests
- tests/unit/test_literal.py::test_value_assignment_list
- tests/unit/test_ticketed_features.py::test_isort_supports_formatting_plugins_issue_1353
- tests/unit/test_ticketed_features.py::test_isort_literals_issue_1358
- # Same here: requires "example_shared_isort_profile"
- tests/unit/test_ticketed_features.py::test_isort_supports_shared_profiles_issue_970
- )
- pytest -s tests/unit/test_importable.py \
- || die "Tests failed with ${EPYTHON}"
- pytest -vv tests/unit ${skipped_tests[@]/#/--deselect } \
- || die "Tests failed with ${EPYTHON}"
-}