summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-21 08:46:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-21 08:46:23 +0100
commite18da76146b0a262cda0f99c9e2204abd09283f6 (patch)
tree895331c8cf5490c3cc04ee0f6588c9bcf968ede2 /dev-python/isort
parentdev-python/pygobject: Version bump to 3.40.0 (diff)
downloadgentoo-e18da76146b0a262cda0f99c9e2204abd09283f6.tar.gz
gentoo-e18da76146b0a262cda0f99c9e2204abd09283f6.tar.bz2
gentoo-e18da76146b0a262cda0f99c9e2204abd09283f6.zip
dev-python/isort: Bump to 5.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest1
-rw-r--r--dev-python/isort/isort-5.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 5ed88ff8be11..1d915f1b1abe 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1 +1,2 @@
DIST isort-5.7.0.tar.gz 169353 BLAKE2B bafd6a0ce81ed80a3c1ad53ce320361ef11bc01a78211ad13b7947aafddd4d9bb5a4fbf65ec01d4c90dce7ebd0a2e3b1c4dcad729b1e27b1dd2c5c90c802eecf SHA512 ae5ff56394f495f6bd86f7581e0f8a67264671553b344b9dc2c5ba0b37f483ae500ebba9882ff5c315b913a689901b17de2eac403e0b4240f913c9e1864bab9f
+DIST isort-5.8.0.tar.gz 167927 BLAKE2B 59b9ee4e63e231026e25833ef8bc4a782ad7b30622d1f6b61fe177fbf0f8663ca953f68cf168abb407d3cb90fe98e29540ec3a8933a5df2ca7ba3e938ba4282f SHA512 ffeee045b5328fa410673464b2ca22d9cd1ba8dd34eff9a430b93e9ce72033100e32e3373308438bcb82b8eb7deea1f2087091e111b1204e35791958ca6944c4
diff --git a/dev-python/isort/isort-5.8.0.ebuild b/dev-python/isort/isort-5.8.0.ebuild
new file mode 100644
index 000000000000..4fb03c0631f5
--- /dev/null
+++ b/dev-python/isort/isort-5.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Some tests run the "isort" command
+ distutils_install_for_testing
+
+ local skipped_tests=(
+ # Fails without -s, run it separately to avoid unnecessary output
+ tests/unit/test_importable.py
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ # Require "example_isort_formatting_plugin", we're not going
+ # to add an example package just to run a few tests
+ tests/unit/test_literal.py::test_value_assignment_list
+ tests/unit/test_ticketed_features.py::test_isort_supports_formatting_plugins_issue_1353
+ tests/unit/test_ticketed_features.py::test_isort_literals_issue_1358
+ # Same here: requires "example_shared_isort_profile"
+ tests/unit/test_ticketed_features.py::test_isort_supports_shared_profiles_issue_970
+ )
+ epytest -s tests/unit/test_importable.py
+ epytest tests/unit ${skipped_tests[@]/#/--deselect }
+}