summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 08:38:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 08:55:23 +0200
commit3091b4f3fd4c717964c2fbb458c95bfeb8ac66b3 (patch)
tree124821798ae20fddcb65b1cbbae1a0dfee07ab82 /dev-python/itypes
parentdev-python/coreschema: Add python@ as maintainer (diff)
downloadgentoo-3091b4f3fd4c717964c2fbb458c95bfeb8ac66b3.tar.gz
gentoo-3091b4f3fd4c717964c2fbb458c95bfeb8ac66b3.tar.bz2
gentoo-3091b4f3fd4c717964c2fbb458c95bfeb8ac66b3.zip
dev-python/itypes: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/itypes')
-rw-r--r--dev-python/itypes/Manifest2
-rw-r--r--dev-python/itypes/itypes-1.1.0.ebuild19
2 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/itypes/Manifest b/dev-python/itypes/Manifest
index cc584c967db6..9c75194091fb 100644
--- a/dev-python/itypes/Manifest
+++ b/dev-python/itypes/Manifest
@@ -1 +1 @@
-DIST itypes-1.1.0.tar.gz 2188 BLAKE2B 5b24790944b130530d4bb3f0ee266c897ebf7946a37133535622f823cc66bd2d2aba838170769b326d706fb123ccd1f4ed7aea8e877b9fe0a9d19692e0c9e0e2 SHA512 fbaf82a82e0685f54eb98bdea722cf9fa230881d1940e2a74306972eb9f99958cb0cc62b858c340b649e092262793b83dcf76d11d36d04755ecf05e7a2c77d81
+DIST itypes-1.1.0.gh.tar.gz 4403 BLAKE2B 62f7d1a96154f313c43764306ab7ea235e0ed8a60180e56760588f03ffbdb948a56b7bec9c63c861b743f6aa1510b0442d41015b944ef777655e7b152f15bbcb SHA512 2f6dd5d655f1031059df8dcfd0a2f76875796a800144e887fb66cb5585949097edb6b9f5e973de2280f43cfeb25ab99d3ca428372fe239c8cd70f385304bcdd7
diff --git a/dev-python/itypes/itypes-1.1.0.ebuild b/dev-python/itypes/itypes-1.1.0.ebuild
index 43805bb673a9..7c0e5aa22446 100644
--- a/dev-python/itypes/itypes-1.1.0.ebuild
+++ b/dev-python/itypes/itypes-1.1.0.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="basic immutable container types for python"
-HOMEPAGE="https://github.com/PavanTatikonda/itypes"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/PavanTatikonda/itypes/"
+SRC_URI="
+ https://github.com/PavanTatikonda/itypes/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}