summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:49:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:49 +0100
commitdb3919cf44d9ffc88ebd59512a850363a8c63869 (patch)
tree8a8feec352bf8a04a0fe9f805d7795f98b96c75b /dev-python/itypes
parentdev-python/coreschema: Migrate to PEP517 build (diff)
downloadgentoo-db3919cf44d9ffc88ebd59512a850363a8c63869.tar.gz
gentoo-db3919cf44d9ffc88ebd59512a850363a8c63869.tar.bz2
gentoo-db3919cf44d9ffc88ebd59512a850363a8c63869.zip
dev-python/itypes: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/itypes')
-rw-r--r--dev-python/itypes/itypes-1.2.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/itypes/itypes-1.2.0-r1.ebuild b/dev-python/itypes/itypes-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..99a0098c43c9
--- /dev/null
+++ b/dev-python/itypes/itypes-1.2.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="basic immutable container types for python"
+HOMEPAGE="https://github.com/PavanTatikonda/itypes/"
+SRC_URI="
+ https://github.com/PavanTatikonda/itypes/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}