summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 08:41:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 08:55:25 +0200
commitdb4f00a1f7fa2ed7683c796d8f295601fb3c392b (patch)
treeb99501c33027619888b7a1bc63206548c6b1eac6 /dev-python/itypes
parentdev-python/itypes: Add python@ as maintainer (diff)
downloadgentoo-db4f00a1f7fa2ed7683c796d8f295601fb3c392b.tar.gz
gentoo-db4f00a1f7fa2ed7683c796d8f295601fb3c392b.tar.bz2
gentoo-db4f00a1f7fa2ed7683c796d8f295601fb3c392b.zip
dev-python/itypes: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/itypes')
-rw-r--r--dev-python/itypes/Manifest1
-rw-r--r--dev-python/itypes/itypes-1.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/itypes/Manifest b/dev-python/itypes/Manifest
index 9c75194091fb..80980a85bf17 100644
--- a/dev-python/itypes/Manifest
+++ b/dev-python/itypes/Manifest
@@ -1 +1,2 @@
DIST itypes-1.1.0.gh.tar.gz 4403 BLAKE2B 62f7d1a96154f313c43764306ab7ea235e0ed8a60180e56760588f03ffbdb948a56b7bec9c63c861b743f6aa1510b0442d41015b944ef777655e7b152f15bbcb SHA512 2f6dd5d655f1031059df8dcfd0a2f76875796a800144e887fb66cb5585949097edb6b9f5e973de2280f43cfeb25ab99d3ca428372fe239c8cd70f385304bcdd7
+DIST itypes-1.2.0.gh.tar.gz 5578 BLAKE2B c4025c2ad54203c4f3bbcd6f369fc6a86d21bd54a63c42acd68a98b6b44404340c3242e3c7a896483860eaa7f3df156fec79a71974e3cbb7b984fd83aa631eb2 SHA512 94421fa3f9ec7d18989332ca518607f09bd9d674e80bbca4a3c7324c20c3ae4e0679457e6a328e50ffe3d94c6db733f092798293133d42c1f07d959e0f837891
diff --git a/dev-python/itypes/itypes-1.2.0.ebuild b/dev-python/itypes/itypes-1.2.0.ebuild
new file mode 100644
index 000000000000..56c99da99047
--- /dev/null
+++ b/dev-python/itypes/itypes-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="basic immutable container types for python"
+HOMEPAGE="https://github.com/PavanTatikonda/itypes/"
+SRC_URI="
+ https://github.com/PavanTatikonda/itypes/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}