summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-03 19:34:28 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-03 19:49:07 +0200
commite42af8b45c21dcf339a04561c3ad601594701bef (patch)
tree7f77fb87c7ed44bbeaee66552bf57b7a84c8c76d /dev-python/jaraco-collections
parentdev-python/zstd: add 1.5.1.0 (diff)
downloadgentoo-e42af8b45c21dcf339a04561c3ad601594701bef.tar.gz
gentoo-e42af8b45c21dcf339a04561c3ad601594701bef.tar.bz2
gentoo-e42af8b45c21dcf339a04561c3ad601594701bef.zip
dev-python/jaraco-collections: add 3.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.5.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 72c20684d7a8..1267d2de2c85 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-3.4.0.tar.gz 14887 BLAKE2B 2c1e87b18dc3ca68fb5b849b30cc0284b8a8daed9b6b2b075a753f7ccf91feb487734a38bb7fc88d29020b0b1980346109551a8bba5d0b3a7f4a491c0dcb1615 SHA512 8e427f98dbcfad3f9042d1f080b2bf8012fdaaf084e230f9b46ff078623b047c2d9dab41ed0303df5dd070abce2a25289281113a97e8ab8d819048d30b8d314a
+DIST jaraco.collections-3.5.0.tar.gz 15001 BLAKE2B 3ddc63fdc8d9c9cf9f25aee0cfa1c6d10c93b337bb77f7f33527986f58bb80ae35fbcc1dcb21aadebb3303a3ee20122134fe27f95ecd4b17c64b6f5ea6e94ae2 SHA512 cf0646b388beefe1aed26c96ae725b2934b7bd9df63e57c51c9c84ad6c758c135e6bb3487e0a6a68fba149234c54f2b0eacd4b260c945f8ffed632bdcb03d88f
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.5.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.5.0.ebuild
new file mode 100644
index 000000000000..010f9dbceca2
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest