summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-15 09:25:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-15 09:34:34 +0100
commit67786af5de075713a26c0773c6ab736eb00d84f8 (patch)
tree24dce0c2c684cc3c4139fe7bbc9cea098f18dd8b /dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild
parentdev-python/configargparse: Bump to 1.4 (diff)
downloadgentoo-67786af5de075713a26c0773c6ab736eb00d84f8.tar.gz
gentoo-67786af5de075713a26c0773c6ab736eb00d84f8.tar.bz2
gentoo-67786af5de075713a26c0773c6ab736eb00d84f8.zip
dev-python/jaraco-envs: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild')
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild
new file mode 100644
index 000000000000..a044f6645ec7
--- /dev/null
+++ b/dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Classes for orchestrating Python (virtual) environments."
+HOMEPAGE="https://github.com/jaraco/jaraco.envs"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/path-py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' 'python3_[67]')"
+# toml is required by setuptools_scm
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+# there are no actual tests, just flake8 etc
+RESTRICT="test"