summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-26 07:26:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-26 07:27:35 +0200
commitbf3e43e7cfb42ee453cf6a2974b1f2b2699dafa5 (patch)
tree8f07eefd05dafdf508b78ae248e4c8c39b6b7501 /dev-python/jaraco-functools
parentdev-python/smbus2: Bump to 0.4.3 (diff)
downloadgentoo-bf3e43e7cfb42ee453cf6a2974b1f2b2699dafa5.tar.gz
gentoo-bf3e43e7cfb42ee453cf6a2974b1f2b2699dafa5.tar.bz2
gentoo-bf3e43e7cfb42ee453cf6a2974b1f2b2699dafa5.zip
dev-python/jaraco-functools: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-functools')
-rw-r--r--dev-python/jaraco-functools/Manifest1
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-3.9.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/Manifest b/dev-python/jaraco-functools/Manifest
index 54226557c09d..aa2d297e4821 100644
--- a/dev-python/jaraco-functools/Manifest
+++ b/dev-python/jaraco-functools/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.functools-3.8.0.tar.gz 16251 BLAKE2B 15735a053b395173de2568d13d54d0a770477f72e138998abb67f24314d13ae1a008a2b373979dfb8b3b8955754758e07eb5981459b793ba4b6839e6aefbdda8 SHA512 923e94f54c46896d89db6b4a0c5d803996dc5caddd6a3ada66f943b58afd1750f5403d10de5ab87f93e57c3eab43806401f7c6b5a8265938793d45cba93df688
DIST jaraco.functools-3.8.1.tar.gz 16210 BLAKE2B 2e49829c4eda4ba9228c8972b1971c1a42bb972e5a7f0ef9994313b4b07cb8395c0b0ccc15c5f285a6a224ad60dec65901742c5f162156c4be96257a9ef9f67c SHA512 0ffd8fc0e973b0ee957cbc074dcae790530c6a944a54ae36e3feee954a59765663b8a734e5c1d1e56975c958b47560eb1f23b510028fee6cf682aeaf175c9460
+DIST jaraco.functools-3.9.0.tar.gz 17221 BLAKE2B 2476e7cc9440ac21abf4c7d4d5af5d98f7a48c6fb55ef93428936265843a0e9bd02b22e8a2a748e7844015c530bc46ad67be8447b0eddb9b7ddcc1522b53c42b SHA512 5ec081aa07e736b6cacc1f6213e3212b4828824e86033b440d4fc630b0a9cf8e67497b37a239e167e421c41852ea6c0c65a4ccd39d73cc7f1cb831f605b86f00
diff --git a/dev-python/jaraco-functools/jaraco-functools-3.9.0.ebuild b/dev-python/jaraco-functools/jaraco-functools-3.9.0.ebuild
new file mode 100644
index 000000000000..5ac1791c2e84
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-3.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.functools/
+ https://pypi.org/project/jaraco.functools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/more-itertools-0.12.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.functools"
+ version = "${PV}"
+ description = "Functools like those found in stdlib"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}functools-${PV}.dist-info || die
+}