summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-26 11:52:14 +0200
committerAmy Winston <amynka@gentoo.org>2016-05-26 22:50:16 +0200
commit9898df39f9be12da5f5482a4934acd95eb41ad82 (patch)
treef21dd5ba37370cf53f724475b680012dc0e76b0c /dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
parentsys-auth/keystone: bups (diff)
downloadgentoo-9898df39f9be12da5f5482a4934acd95eb41ad82.tar.gz
gentoo-9898df39f9be12da5f5482a4934acd95eb41ad82.tar.bz2
gentoo-9898df39f9be12da5f5482a4934acd95eb41ad82.zip
dev-python/jaraco-logging: bump to 1.5, EAPI=6
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/jaraco-logging/jaraco-logging-1.5.ebuild')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-1.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild b/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
new file mode 100644
index 000000000000..10cbefa835e8
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="https://github.com/jaraco/jaraco.logging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}