summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-24 01:58:09 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-24 02:05:47 +0200
commit94cca6852a54b81efae774f3711ce76d6ebc3314 (patch)
tree87c801c3496d98766645d712809efe01c9e470ec /dev-python/jaraco-text
parentnet-analyzer/fail2ban: Stable for AMD64 HPPA x86 too. (diff)
downloadgentoo-94cca6852a54b81efae774f3711ce76d6ebc3314.tar.gz
gentoo-94cca6852a54b81efae774f3711ce76d6ebc3314.tar.bz2
gentoo-94cca6852a54b81efae774f3711ce76d6ebc3314.zip
dev-python/jaraco-text: bump to 1.10.1, add Python 3.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest1
-rw-r--r--dev-python/jaraco-text/jaraco-text-1.10.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index c8df7b2fb869..c51c937b450a 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,2 +1,3 @@
+DIST jaraco.text-1.10.1.tar.gz 8790 BLAKE2B 268c13a9a84c4b29ac9141d8a43c716d8248b87c2b71f6bb8a34c2cf1568acdd012e84b1be0469f70ee8e102f723e218b6d551a9bd0cab5192a28d712ed39f03 SHA512 5c09b90f586d5ddf7419013f7e36814598337c257e6bd1c1eec993d7df021440798ec9300a6d45c960c5458c4197b458d1863f478b60a9a003241e98a644f28e
DIST jaraco.text-1.7.tar.gz 7020 BLAKE2B 33b17223cfcbc07c096803c7be698458d72f869399161476b718904cf4ceafe1178bbf8cd71cd8c229efafcc234fbdaa751c9ef72f01cd4ab6c4333c91c1c340 SHA512 b1418dc19b52e353da3b2a332ffbc9a4201c6696ecc962722e25fd6549c8748a9dbea2cf76f658111aa4e3fd411ee999b526fa4d8148259866dbe95ebc4cfa95
DIST jaraco.text-1.8.tar.gz 7364 BLAKE2B 60e3ce561ca5c6dca3093a51f8397e925279882ee5b1c02e5359b518f2344481f3d86a927fbd1c7fc903e3207c46cd052a6efbcfac693debce721884188ab87a SHA512 7f13eee9553d7531bf2f51af1b1c7fbb9d778cf082e6eb49948fc0943b7eb5a0268ec51b363ae9e96df854e0af5e38fbc4a679c746160e422759c044d4a33654
diff --git a/dev-python/jaraco-text/jaraco-text-1.10.1.ebuild b/dev-python/jaraco-text/jaraco-text-1.10.1.ebuild
new file mode 100644
index 000000000000..1e7cd931da37
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-1.10.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.text"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-collections[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/namespace-jaraco[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${PDEPEND}
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}