summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-07-04 00:16:12 +0200
committerLouis Sautier <sbraz@gentoo.org>2019-07-04 01:36:24 +0200
commitef3b9e1459534821f257d5c8f0c4d3284aface0a (patch)
tree32f983462ac1566934f6ba0565357da303e4e2fc /dev-python/jaraco-text
parentdev-python/fs: drop support for pypy (diff)
downloadgentoo-ef3b9e1459534821f257d5c8f0c4d3284aface0a.tar.gz
gentoo-ef3b9e1459534821f257d5c8f0c4d3284aface0a.tar.bz2
gentoo-ef3b9e1459534821f257d5c8f0c4d3284aface0a.zip
dev-python/jaraco-text: bump to 3.0, switches to pkgutil
This new version also lifts the circular dependency on dev-python/jaraco-collections. Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest1
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index 0a0014b4bc2f..db56948aa3d3 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.text-1.10.1.tar.gz 8790 BLAKE2B 268c13a9a84c4b29ac9141d8a43c716d8248b87c2b71f6bb8a34c2cf1568acdd012e84b1be0469f70ee8e102f723e218b6d551a9bd0cab5192a28d712ed39f03 SHA512 5c09b90f586d5ddf7419013f7e36814598337c257e6bd1c1eec993d7df021440798ec9300a6d45c960c5458c4197b458d1863f478b60a9a003241e98a644f28e
DIST jaraco.text-1.8.tar.gz 7364 BLAKE2B 60e3ce561ca5c6dca3093a51f8397e925279882ee5b1c02e5359b518f2344481f3d86a927fbd1c7fc903e3207c46cd052a6efbcfac693debce721884188ab87a SHA512 7f13eee9553d7531bf2f51af1b1c7fbb9d778cf082e6eb49948fc0943b7eb5a0268ec51b363ae9e96df854e0af5e38fbc4a679c746160e422759c044d4a33654
+DIST jaraco.text-3.0.tar.gz 12082 BLAKE2B 474a3701460dc899015ef0331f2d4de996915e4b840dfcbb8963fd2eb98571bf7f398285dd4df0a0df36e5d1ba8ce04fa59d396dede5ac059c2b991f6a203a1d SHA512 449b917919f074e0b8a285083163fb5141fdee0db0e6d49c58c8e07ca6f284b5d53d01174e266bf8d21914870574672425abf9b094e815d0d9f0c94b1219de16
diff --git a/dev-python/jaraco-text/jaraco-text-3.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.0.ebuild
new file mode 100644
index 000000000000..cc95fcac5347
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.text"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ # note: eclass may default to --skip-build in the future
+ distutils-r1_python_install --skip-build
+}