summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-05 20:46:31 -0500
committerTim Harder <radhermit@gentoo.org>2018-02-05 20:51:59 -0500
commitcdb4a4c747fcabfbdbc5c709c559b1669d0b0ae6 (patch)
treeab26c153efd6d848df11e12372ab4d1db2740289 /dev-python/jedi/files/jedi-0.11.1-exclude-tests.patch
parentdev-python/parso: initial import, required by latest version of jedi (diff)
downloadgentoo-cdb4a4c747fcabfbdbc5c709c559b1669d0b0ae6.tar.gz
gentoo-cdb4a4c747fcabfbdbc5c709c559b1669d0b0ae6.tar.bz2
gentoo-cdb4a4c747fcabfbdbc5c709c559b1669d0b0ae6.zip
dev-python/jedi: version bump to 0.11.1
Diffstat (limited to 'dev-python/jedi/files/jedi-0.11.1-exclude-tests.patch')
-rw-r--r--dev-python/jedi/files/jedi-0.11.1-exclude-tests.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jedi/files/jedi-0.11.1-exclude-tests.patch b/dev-python/jedi/files/jedi-0.11.1-exclude-tests.patch
new file mode 100644
index 000000000000..a85af80d4c98
--- /dev/null
+++ b/dev-python/jedi/files/jedi-0.11.1-exclude-tests.patch
@@ -0,0 +1,26 @@
+From 4e52acbf26b6d52e26e757cb04817d17c5464331 Mon Sep 17 00:00:00 2001
+From: Dave Halter <davidhalter88@gmail.com>
+Date: Sun, 7 Jan 2018 14:13:21 +0100
+Subject: [PATCH] Using setup.py build should not include part of tests
+
+It looks like that we have to not only exclude the test package but also 'test.*'. Thanks to @david-geiger for noticing this. Fixes #1024.
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 3f3b7e54..c7081858 100755
+--- a/setup.py
++++ b/setup.py
+@@ -32,7 +32,7 @@ setup(name='jedi',
+ license='MIT',
+ keywords='python completion refactoring vim',
+ long_description=readme,
+- packages=find_packages(exclude=['test']),
++ packages=find_packages(exclude=['test', 'test.*']),
+ install_requires=install_requires,
+ extras_require={'dev': ['docopt']},
+ package_data={'jedi': ['evaluate/compiled/fake/*.pym']},
+--
+2.16.1
+