summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-22 06:31:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-22 06:46:34 +0200
commit8ccffd1c6c6b7b4cbb50c3895700cb34670705a4 (patch)
tree86502e60ac7793d68276f461afa321ebab602284 /dev-python/jellyfish/jellyfish-0.8.2.ebuild
parentdev-python/six: Bump to 1.15.0 (diff)
downloadgentoo-8ccffd1c6c6b7b4cbb50c3895700cb34670705a4.tar.gz
gentoo-8ccffd1c6c6b7b4cbb50c3895700cb34670705a4.tar.bz2
gentoo-8ccffd1c6c6b7b4cbb50c3895700cb34670705a4.zip
dev-python/jellyfish: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jellyfish/jellyfish-0.8.2.ebuild')
-rw-r--r--dev-python/jellyfish/jellyfish-0.8.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jellyfish/jellyfish-0.8.2.ebuild b/dev-python/jellyfish/jellyfish-0.8.2.ebuild
new file mode 100644
index 000000000000..f013a652a02d
--- /dev/null
+++ b/dev-python/jellyfish/jellyfish-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
+HOMEPAGE="https://github.com/jamesturk/jellyfish https://pypi.org/project/jellyfish/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( build/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ cp -r testdata "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ pytest -vv lib/jellyfish/test.py || die "tests failed with ${EPYTHON}"
+}