summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2019-12-15 22:29:29 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2019-12-15 22:40:17 +0100
commit541983d53d38eaca1bd5bc653b9cca18a78be0d3 (patch)
treec1436db365756a24eefe9c805288fbd836b9c131 /dev-python/jikanpy/jikanpy-3.4.2.ebuild
parentdev-tcltk/tkimg: remove old versions (diff)
downloadgentoo-541983d53d38eaca1bd5bc653b9cca18a78be0d3.tar.gz
gentoo-541983d53d38eaca1bd5bc653b9cca18a78be0d3.tar.bz2
gentoo-541983d53d38eaca1bd5bc653b9cca18a78be0d3.zip
dev-python/jikanpy-3.4.2: version bump
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-python/jikanpy/jikanpy-3.4.2.ebuild')
-rw-r--r--dev-python/jikanpy/jikanpy-3.4.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jikanpy/jikanpy-3.4.2.ebuild b/dev-python/jikanpy/jikanpy-3.4.2.ebuild
new file mode 100644
index 000000000000..52e861dcab31
--- /dev/null
+++ b/dev-python/jikanpy/jikanpy-3.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for jikan.moe API."
+HOMEPAGE="https://pypi.org/project/jikanpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"