summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-07 01:54:17 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-07 01:56:17 +0200
commite82ac4a90fd126f49cfefd71b952d87657f25897 (patch)
tree25c2d4162651db2fc82c9e32e36ec57ccbf69575 /dev-python/jinja/jinja-2.9.6.ebuild
parentdev-python/setuptools: Version bump to 34.3.3 (diff)
downloadgentoo-e82ac4a90fd126f49cfefd71b952d87657f25897.tar.gz
gentoo-e82ac4a90fd126f49cfefd71b952d87657f25897.tar.bz2
gentoo-e82ac4a90fd126f49cfefd71b952d87657f25897.zip
dev-python/jinja: Version bump to 2.9.6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/jinja/jinja-2.9.6.ebuild')
-rw-r--r--dev-python/jinja/jinja-2.9.6.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/jinja/jinja-2.9.6.ebuild b/dev-python/jinja/jinja-2.9.6.ebuild
new file mode 100644
index 000000000000..6ac8329e0787
--- /dev/null
+++ b/dev-python/jinja/jinja-2.9.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.python.org/pypi/Jinja2"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/jinja:compat"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+ local mydistutilsargs=()
+
+ if [[ ${EPYTHON} == python* ]]; then
+ mydistutilargs+=( --with-debugsupport )
+ fi
+
+ "${@}"
+}
+
+python_compile() {
+ wrap_opts distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ext/Vim/*
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/Babel; then
+ elog "For i18n support, please emerge dev-python/Babel."
+ fi
+}