summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-14 10:56:12 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-14 10:56:12 -0700
commit6820957fb0fb6525799b5c54d5cfc81cb6bb621a (patch)
treeeb7d38e20254bd884431b1afceb892628446ab75 /dev-python/jira/jira-1.0.10.ebuild
parentdev-python/jira: Add python3_5 to PYTHON_COMPAT (diff)
downloadgentoo-6820957fb0fb6525799b5c54d5cfc81cb6bb621a.tar.gz
gentoo-6820957fb0fb6525799b5c54d5cfc81cb6bb621a.tar.bz2
gentoo-6820957fb0fb6525799b5c54d5cfc81cb6bb621a.zip
dev-python/jira: version bump to 1.0.10
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/jira/jira-1.0.10.ebuild')
-rw-r--r--dev-python/jira/jira-1.0.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jira/jira-1.0.10.ebuild b/dev-python/jira/jira-1.0.10.ebuild
new file mode 100644
index 000000000000..78163a87f22e
--- /dev/null
+++ b/dev-python/jira/jira-1.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for interacting with the JIRA REST API"
+HOMEPAGE="https://jira.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="filemagic ipython oauth"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ filemagic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ oauth? (
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/tlslite[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"