summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-03-13 01:01:22 +0000
committerBrian Dolbec <dolsen@gentoo.org>2018-03-13 23:56:33 +0000
commitfebd86d19c138d94e7fdc310728ac91b1ce42ad1 (patch)
treede81a00f937195b00e3f94ba7086846c2cb02413 /dev-python/jira/jira-1.0.14.ebuild
parentnet-misc/crossbar: Version bump (diff)
downloadgentoo-febd86d19c138d94e7fdc310728ac91b1ce42ad1.tar.gz
gentoo-febd86d19c138d94e7fdc310728ac91b1ce42ad1.tar.bz2
gentoo-febd86d19c138d94e7fdc310728ac91b1ce42ad1.zip
dev-python/jira: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/jira/jira-1.0.14.ebuild')
-rw-r--r--dev-python/jira/jira-1.0.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jira/jira-1.0.14.ebuild b/dev-python/jira/jira-1.0.14.ebuild
new file mode 100644
index 000000000000..08a583cdb83e
--- /dev/null
+++ b/dev-python/jira/jira-1.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for interacting with the JIRA REST API"
+HOMEPAGE="https://jira.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="filemagic ipython oauth"
+
+DEPEND="
+ >=dev-python/pbr-3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ filemagic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ oauth? (
+ || ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ )
+ "