summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jmespath
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jmespath')
-rw-r--r--dev-python/jmespath/Manifest2
-rw-r--r--dev-python/jmespath/jmespath-0.5.0.ebuild26
-rw-r--r--dev-python/jmespath/jmespath-0.7.1.ebuild26
-rw-r--r--dev-python/jmespath/metadata.xml14
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/jmespath/Manifest b/dev-python/jmespath/Manifest
new file mode 100644
index 000000000000..ef4e7118232b
--- /dev/null
+++ b/dev-python/jmespath/Manifest
@@ -0,0 +1,2 @@
+DIST jmespath-0.5.0.tar.gz 18175 SHA256 c3243fb93f914df1852cc3699115c87982009860290b60910c1b2715bec238c2 SHA512 7ea11fa1f011585065a53a8b5286bab0c2422b1c553e89f1c3d543c3018d7d532d44b021e2654a1cd32e4bfbc384897b35f35a30b9b7439e9834135428bc9647 WHIRLPOOL fd1aa83c7a224b7f9d8bea513e83fb2e3ee54656c8661a1b36b1db1c24b0c59ea3de9adaf64cf17d1dfeffd333aa8895dd3ce8f8ec9e6f53e4260ec283d1da51
+DIST jmespath-0.7.1.tar.gz 19696 SHA256 cd5a12ee3dfa470283a020a35e69e83b0700d44fe413014fd35ad5584c5f5fd1 SHA512 66f3e1bd084c090c8a2bb11ecf873066464834b515a421e1c832b1de26e8de8ea875d9ec3e9bf471c1a2170b102206f2b9e59ec09bba1bbecb278e2713f2446f WHIRLPOOL a571e8f83ca57e9742e819a5154f77f483ef96984ffe04dcaed3629c0a63b8094bfa18526c06688981a626a52fd96f95b777ec5f8209f0db60a5adaeb2ff3eaf
diff --git a/dev-python/jmespath/jmespath-0.5.0.ebuild b/dev-python/jmespath/jmespath-0.5.0.ebuild
new file mode 100644
index 000000000000..962375bbc9d3
--- /dev/null
+++ b/dev-python/jmespath/jmespath-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON Matching Expressions"
+HOMEPAGE="https://github.com/boto/jmespath https://pypi.python.org/pypi/jmespath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/jmespath/jmespath-0.7.1.ebuild b/dev-python/jmespath/jmespath-0.7.1.ebuild
new file mode 100644
index 000000000000..58c2e6ef429b
--- /dev/null
+++ b/dev-python/jmespath/jmespath-0.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON Matching Expressions"
+HOMEPAGE="https://github.com/boto/jmespath https://pypi.python.org/pypi/jmespath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/jmespath/metadata.xml b/dev-python/jmespath/metadata.xml
new file mode 100644
index 000000000000..d1bd75aebfc7
--- /dev/null
+++ b/dev-python/jmespath/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jmespath</remote-id>
+ <remote-id type="github">boto/jmespath</remote-id>
+ </upstream>
+</pkgmetadata>