summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-24 20:40:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-24 20:40:31 +0200
commitd7ec5b3556fa1314b8935e6d7809f8a4a060ee18 (patch)
tree10704904450eee63166175e9616f213a2bd4c535 /dev-python/jmespath
parentdev-python/imapclient: Remove old (diff)
downloadgentoo-d7ec5b3556fa1314b8935e6d7809f8a4a060ee18.tar.gz
gentoo-d7ec5b3556fa1314b8935e6d7809f8a4a060ee18.tar.bz2
gentoo-d7ec5b3556fa1314b8935e6d7809f8a4a060ee18.zip
dev-python/jmespath: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jmespath')
-rw-r--r--dev-python/jmespath/Manifest1
-rw-r--r--dev-python/jmespath/files/jmespath-1.0.0-py311.patch26
-rw-r--r--dev-python/jmespath/jmespath-1.0.0.ebuild43
3 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/jmespath/Manifest b/dev-python/jmespath/Manifest
index c783c9560f7e..6e874ab2b77a 100644
--- a/dev-python/jmespath/Manifest
+++ b/dev-python/jmespath/Manifest
@@ -1,2 +1 @@
-DIST jmespath.py-1.0.0.gh.tar.gz 80829 BLAKE2B dcd5e61ef846c5bcd9ac59480f909b05310dbe785c21e97c81981db90d104d17a3319f766b8926e8c8e3ae8b0e2164051d5312c74fa9c16979d802aafd286654 SHA512 d55ea1c4041e1a5043b3e3b7efcd1e561b92a394e3facbe96b069ff6a9a11c20553e62cfbc5fea966670c71376f9f9ccc24d8905f253e0f1d96dd7a588cc3e44
DIST jmespath.py-1.0.1.gh.tar.gz 80936 BLAKE2B 9dfcdf4a8359d0e7c5f333e349d12e5c438693cf81b64df1a8a3b7211304ee228e9579be528a9b35ee0e4289539a5b4e214fcb9cb42d2b3fdbdd2e1a83975bc2 SHA512 c1676a4b7565d25c2948569005c503a0ca33908de6ed16536767da2c00c634e4ee345bcaf88a01bf6cd2996aaf722faaedff80061ab65ee77e5bc0f494f86a70
diff --git a/dev-python/jmespath/files/jmespath-1.0.0-py311.patch b/dev-python/jmespath/files/jmespath-1.0.0-py311.patch
deleted file mode 100644
index 90c7bef9beee..000000000000
--- a/dev-python/jmespath/files/jmespath-1.0.0-py311.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 325d8111a924a951d8778c9fc1dbce30be267435 Mon Sep 17 00:00:00 2001
-From: Karthikeyan Singaravelan <tir.karthi@gmail.com>
-Date: Wed, 10 Mar 2021 14:15:36 +0000
-Subject: [PATCH] Use list for random.sample since using a set has been
- deprecated since Python 3.9
-
----
- jmespath/parser.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/jmespath/parser.py b/jmespath/parser.py
-index eeac38f..4706688 100644
---- a/jmespath/parser.py
-+++ b/jmespath/parser.py
-@@ -489,7 +489,7 @@ class Parser(object):
- lex_position, actual_value, actual_type, message)
-
- def _free_cache_entries(self):
-- for key in random.sample(self._CACHE.keys(), int(self._MAX_SIZE / 2)):
-+ for key in random.sample(list(self._CACHE.keys()), int(self._MAX_SIZE / 2)):
- self._CACHE.pop(key, None)
-
- @classmethod
---
-2.35.1
-
diff --git a/dev-python/jmespath/jmespath-1.0.0.ebuild b/dev-python/jmespath/jmespath-1.0.0.ebuild
deleted file mode 100644
index 7d281153bda1..000000000000
--- a/dev-python/jmespath/jmespath-1.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=jmespath.py-${PV}
-DESCRIPTION="JSON Matching Expressions"
-HOMEPAGE="
- https://github.com/jmespath/jmespath.py/
- https://pypi.org/project/jmespath/
-"
-SRC_URI="
- https://github.com/jmespath/jmespath.py/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${P}-py311.patch"
-)
-
-src_prepare() {
- # leftover import
- sed -i -e '/nose/d' extra/test_hypothesis.py || die
- distutils-r1_src_prepare
-}