summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 19:05:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 19:33:07 +0200
commit0b9530bec5e66353d2d76a766f779e2e9879ddf2 (patch)
tree0f597af4201b1a53504f61aece750d3c421e4610 /dev-python/joblib
parentdev-python/isodate: Remove old (diff)
downloadgentoo-0b9530bec5e66353d2d76a766f779e2e9879ddf2.tar.gz
gentoo-0b9530bec5e66353d2d76a766f779e2e9879ddf2.tar.bz2
gentoo-0b9530bec5e66353d2d76a766f779e2e9879ddf2.zip
dev-python/joblib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/joblib')
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-0.12.2.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index af3ac1f1dc3e..df1468d24256 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1,2 +1 @@
-DIST joblib-0.12.2.tar.gz 289249 BLAKE2B 247a8bce753ece235877540b829bdc9546b3a6d7610b09592217bf9d47fd038a5e75f649224b76832825e77d76ae46443984de3d83558cdbd4d816d8f610e8b0 SHA512 9bf93c89681f59d17e735c228d3379df5dff67b4365b59ddea1a062f9547c376e5870e4ece83af8e7cda1ae30e2a2893a4a009e03b7fec798d3574e8ab060267
DIST joblib-0.14.1.tar.gz 338930 BLAKE2B 6b84c43be8b8d32f28a3dbc3e6f4ce15574cf20571805501972d162d4b076c1fe144a9790b8132821f0acd439c8859873038813c7bdd4163d0535eca36a1a8fa SHA512 079eb4321ed95c8f05399abca2a1c46ecb7c28fe9a3a50b6eb106a2bd2f3566fb25bca59022fafbfcee5069f078921421d799eeb29a796f8f98881491cf9be08
diff --git a/dev-python/joblib/joblib-0.12.2.ebuild b/dev-python/joblib/joblib-0.12.2.ebuild
deleted file mode 100644
index 93796a110918..000000000000
--- a/dev-python/joblib/joblib-0.12.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to provide lightweight pipelining in Python"
-HOMEPAGE="https://joblib.readthedocs.io/en/latest/
- https://github.com/joblib/joblib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html -c doc/ doc/ doc/html || die "docs failed installation"
- fi
-}
-
-python_test() {
- # https://github.com/joblib/joblib/issues/143
- if [[ "${EPYTHON}" == pypy ]]; then
- sed -e 's:test_func_inspect_errors:_&:' -i ${PN}/test/test_func_inspect.py || die
- sed -e 's:test_parallel_pickling:_&:' -i ${PN}/test/test_parallel.py || die
- fi
-
- py.test -v
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
-}