summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-25 00:39:48 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-25 00:39:58 +0000
commit759459fffe014945e1e564cceb31935b7dc3ca16 (patch)
tree45ff1d0a78fdb0af43626e44da8e9689ef93dfeb /dev-python/jpype/jpype-0.6.1.ebuild
parentdev-java/japitools: EAPI 5 bump. (diff)
downloadgentoo-759459fffe014945e1e564cceb31935b7dc3ca16.tar.gz
gentoo-759459fffe014945e1e564cceb31935b7dc3ca16.tar.bz2
gentoo-759459fffe014945e1e564cceb31935b7dc3ca16.zip
dev-python/jpype: Add jpype to the tree.
JPype is an effort to allow Python programs full access to Java class libraries. Gentoo-Bug: https://bugs.gentoo.org/304325 URL: https://github.com/originell/jpype Package-Manager: portage-2.2.26 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/jpype/jpype-0.6.1.ebuild')
-rw-r--r--dev-python/jpype/jpype-0.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jpype/jpype-0.6.1.ebuild b/dev-python/jpype/jpype-0.6.1.ebuild
new file mode 100644
index 000000000000..f8d469f21b5d
--- /dev/null
+++ b/dev-python/jpype/jpype-0.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 java-pkg-opt-2
+
+DESCRIPTION="JPype is an effort to allow Python programs full access to Java class libraries"
+HOMEPAGE="https://github.com/originell/jpype"
+SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=virtual/jdk-1.6"
+
+pkg_setup() {
+ java-pkg_init
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_install() {
+ use doc && local DOCS=( doc/* )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install
+}