summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-10 23:30:00 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-10 23:30:00 +0100
commit70232809d4be3521b6533bde7aaeb45edb09b11e (patch)
tree2a9ffd25159a5d821dc7c11e5d222ffca97ac84f /dev-python/jpype/jpype-0.6.2.ebuild
parentdev-java/cssparser: remove old. (diff)
downloadgentoo-70232809d4be3521b6533bde7aaeb45edb09b11e.tar.gz
gentoo-70232809d4be3521b6533bde7aaeb45edb09b11e.tar.bz2
gentoo-70232809d4be3521b6533bde7aaeb45edb09b11e.zip
dev-python/jpype: version bump.
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/jpype/jpype-0.6.2.ebuild')
-rw-r--r--dev-python/jpype/jpype-0.6.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jpype/jpype-0.6.2.ebuild b/dev-python/jpype/jpype-0.6.2.ebuild
new file mode 100644
index 000000000000..0b1edf0d02fa
--- /dev/null
+++ b/dev-python/jpype/jpype-0.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit java-pkg-2 distutils-r1
+
+DESCRIPTION="JPype is an effort to allow Python programs full access to Java class librairies"
+HOMEPAGE="https://github.com/originell/jpype"
+SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=virtual/jdk-1.6"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_install() {
+ use doc && local DOCS=( doc/* )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install
+}