summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2021-02-23 17:20:05 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-24 10:30:54 +0200
commitf213c79557c06baf451d15059cb076853261293d (patch)
tree1b160a9023208eb182b97ccfc945a73ebbc3cfad /dev-python/js2py
parentdev-util/shards: bump up to 0.14.0 (diff)
downloadgentoo-f213c79557c06baf451d15059cb076853261293d.tar.gz
gentoo-f213c79557c06baf451d15059cb076853261293d.tar.bz2
gentoo-f213c79557c06baf451d15059cb076853261293d.zip
dev-python/js2py: new package; add version 0.70_p20210218
JavaScript to Python Translator & JavaScript interpreter in Python Signed-off-by: Maciej Barć <xgqt@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/js2py')
-rw-r--r--dev-python/js2py/Manifest1
-rw-r--r--dev-python/js2py/js2py-0.70_p20210218.ebuild45
-rw-r--r--dev-python/js2py/metadata.xml16
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/js2py/Manifest b/dev-python/js2py/Manifest
new file mode 100644
index 000000000000..d36aba4b7bb7
--- /dev/null
+++ b/dev-python/js2py/Manifest
@@ -0,0 +1 @@
+DIST Js2Py-0.70_p20210218.tar.gz 1969615 BLAKE2B 4702b2e771bfd2a5158a3539c33932335816c74f9dbd132679036aa2b7e53796764dd852e92d72a35ecc31efa34b849776c45d8c81e80f85f59308edf0996f00 SHA512 757c895bc0ba933020336a70473ec4455cb93c17040a39f17d645782011ea72273291448f3448ffd34658b48ada45b77facf3d326133f1c0d63e2e26e2cd7f30
diff --git a/dev-python/js2py/js2py-0.70_p20210218.ebuild b/dev-python/js2py/js2py-0.70_p20210218.ebuild
new file mode 100644
index 000000000000..89897bdcda22
--- /dev/null
+++ b/dev-python/js2py/js2py-0.70_p20210218.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_COMMIT="ea16b519a0f72e17416859a57890b8388fce6e39"
+
+MY_PN="Js2Py"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
+HOMEPAGE="
+ http://piter.io/projects/js2py/
+ https://github.com/PiotrDabkowski/Js2Py/
+ https://pypi.org/project/Js2Py/
+"
+SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_COMMIT}"
+
+python_test() {
+ pushd ./tests >/dev/null || die
+
+ # Tests require "node_failed.txt" file where the logs are kept
+ [ -f ./node_failed.txt ] && rm ./node_failed.txt
+ touch ./node_failed.txt || die
+
+ "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
+
+ popd >/dev/null || die
+}
diff --git a/dev-python/js2py/metadata.xml b/dev-python/js2py/metadata.xml
new file mode 100644
index 000000000000..03e41f2cd8e4
--- /dev/null
+++ b/dev-python/js2py/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PiotrDabkowski/Js2Py</remote-id>
+ <remote-id type="pypi">Js2Py</remote-id>
+ </upstream>
+</pkgmetadata>