summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 22:50:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 23:22:46 +0200
commit03011671a924070a92672e6b19cd2aeca59e0bb5 (patch)
treef0895900dee06090ea88b51ebc24a417e6f61d98 /dev-python/jsondiff/jsondiff-1.3.0.ebuild
parentmail-client/thunderbird-bin: bump to v78.10.0 (diff)
downloadgentoo-03011671a924070a92672e6b19cd2aeca59e0bb5.tar.gz
gentoo-03011671a924070a92672e6b19cd2aeca59e0bb5.tar.bz2
gentoo-03011671a924070a92672e6b19cd2aeca59e0bb5.zip
dev-python/jsondiff: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsondiff/jsondiff-1.3.0.ebuild')
-rw-r--r--dev-python/jsondiff/jsondiff-1.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jsondiff/jsondiff-1.3.0.ebuild b/dev-python/jsondiff/jsondiff-1.3.0.ebuild
new file mode 100644
index 000000000000..719f5a89b88a
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/"
+SRC_URI="
+ https://github.com/fzumstein/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}