summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:06:30 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:43:46 -0500
commitc653195222b711b2421a15ab1c15cbacafe1c916 (patch)
tree6eb0daa6408cb8b912b5888c7571dd274d410804 /dev-python/jsonext/jsonext-0.4.2.ebuild
parentdev-python/arrow: 0.13.1 bump (diff)
downloadgentoo-c653195222b711b2421a15ab1c15cbacafe1c916.tar.gz
gentoo-c653195222b711b2421a15ab1c15cbacafe1c916.tar.bz2
gentoo-c653195222b711b2421a15ab1c15cbacafe1c916.zip
dev-python/jsonext: initial add for a chain to openstack
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/jsonext/jsonext-0.4.2.ebuild')
-rw-r--r--dev-python/jsonext/jsonext-0.4.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/jsonext/jsonext-0.4.2.ebuild b/dev-python/jsonext/jsonext-0.4.2.ebuild
new file mode 100644
index 000000000000..7603043762e3
--- /dev/null
+++ b/dev-python/jsonext/jsonext-0.4.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Well-structured helpers for serializing commonly encountered structures to JSON."
+HOMEPAGE="https://github.com/mbr/jsonext"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND=""