summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-03-02 13:06:40 +0100
committerSebastian Pipping <sping@gentoo.org>2020-03-02 13:08:59 +0100
commitad51f8aee2da702b83f5a905f32be6d54e6e899d (patch)
tree5874b1e2b4442df7c06cf7a877b53ae93c5df556 /dev-python/jsonpickle/jsonpickle-1.3.ebuild
parentdev-libs/libressl: stable 3.0.2 for ia64, bug #704228 (diff)
downloadgentoo-ad51f8aee2da702b83f5a905f32be6d54e6e899d.tar.gz
gentoo-ad51f8aee2da702b83f5a905f32be6d54e6e899d.tar.bz2
gentoo-ad51f8aee2da702b83f5a905f32be6d54e6e899d.zip
dev-python/jsonpickle: 1.3
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'dev-python/jsonpickle/jsonpickle-1.3.ebuild')
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/jsonpickle-1.3.ebuild b/dev-python/jsonpickle/jsonpickle-1.3.ebuild
new file mode 100644
index 000000000000..48d7956ab09f
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl.
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ "
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && { python_setup python2_7 && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html || die; }
+}
+
+python_test() {
+ # An apparent regression in tests
+ # https://github.com/jsonpickle/jsonpickle/issues/124
+ einfo "testsuite has optional tests for package demjson"
+ ${PYTHON} tests/runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/html/. )
+ distutils-r1_python_install_all
+}