summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-07 16:00:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-07 16:00:28 +0100
commit78ba77f4dce2d911621a260edbb0a44748493ca8 (patch)
tree566943dacfd30f7db1b1143024209aaeef04140b /dev-python/jsonpickle
parentdev-python/llfuse: Remove redundant versions (diff)
downloadgentoo-78ba77f4dce2d911621a260edbb0a44748493ca8.tar.gz
gentoo-78ba77f4dce2d911621a260edbb0a44748493ca8.tar.bz2
gentoo-78ba77f4dce2d911621a260edbb0a44748493ca8.zip
dev-python/jsonpickle: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest1
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.9.3.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index f62c8e7599d5..cfe34f32fcc6 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1,3 +1,2 @@
-DIST jsonpickle-0.9.3.tar.gz 60489 BLAKE2B 4767809a3bd5816343e9081bdaf45cdec8dfd1e28b832675e01ae415c1ac081d0a84e2827051520999d11d0dc28a62bdd09285cf384fff0f941d3a571064e2bf SHA512 38de2ab2c15e0e28323a8cc83b0c0b0631f2f678f620e8738fee19c71492f011aa7eec428b859574a0066b9e24a08bde911a283736757964035befe3042f2e06
DIST jsonpickle-1.2.tar.gz 74693 BLAKE2B 65f9c18b8693351995f84815d27f2d86ab65fe7a620cda0d346b88db56de45ff6aa21b7ae941e8820e16e184d9a5ac55d56caf112f3930083e63b50751fe2dd8 SHA512 0a5bfb2e77175c9174ee1783301c613e25fcfa60f07e610206d1e1e34053e90b21b12bc1b1045dd03ff2d4efe5940d85d852800037ca01397994c022f0ffb2c6
DIST jsonpickle-1.3.tar.gz 76571 BLAKE2B 797ac90d1aacb620d9917bd2a34dbc960739b29f64d7bc003c934333fc0d836657a4907a965725248b2f9489876ae251440eab3888112f158c28f19e33efe036 SHA512 5e7faa32f4fd2da88d9cfea8c0355121ece12aa1b4434845e6bd679718f433e5c27835b405f833a31d69d09d7a6ae6c3d5e4bf1f6dc9c50c7ff1690cf82271b0
diff --git a/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild b/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild
deleted file mode 100644
index 96d0e161df1c..000000000000
--- a/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# There are optional json backends serializer/deserializers in addition to those selected here
-# jsonlib, yajl. demjson added
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- dev-python/demjson[${PYTHON_USEDEP}]
- "
-DEPEND="test? ( ${RDEPEND} )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
-
-python_prepare_all() {
- # Prevent un-needed d'loading during doc build
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html
-}
-
-python_test() {
- # An apparent regression in tests
- # https://github.com/jsonpickle/jsonpickle/issues/124
- einfo "testsuite has optional tests for package demjson"
- ${PYTHON} tests/runtests.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/html/. )
- distutils-r1_python_install_all
-}