summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 08:50:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-14 08:50:22 +0100
commit1fd0b952862273476933a7cc8a4315ddba8ba7df (patch)
treefcadf44823aa9fa0a327d18ff6249f989e0eba79 /dev-python/jsonpointer/jsonpointer-2.1.ebuild
parentdev-python/jsonpatch: Bump to 1.32 (diff)
downloadgentoo-1fd0b952862273476933a7cc8a4315ddba8ba7df.tar.gz
gentoo-1fd0b952862273476933a7cc8a4315ddba8ba7df.tar.bz2
gentoo-1fd0b952862273476933a7cc8a4315ddba8ba7df.zip
dev-python/jsonpointer: Bump to 2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-2.1.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-2.1.ebuild b/dev-python/jsonpointer/jsonpointer-2.1.ebuild
new file mode 100644
index 000000000000..fa4a6245c51e
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}