summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-05 10:13:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-05 10:13:43 +0200
commit6c690130a12b095ee0a9701dcc1749f27558da61 (patch)
treeb42e3a530c53940af6f0c63c34e44c75b23d93bb /dev-python/jupyter-core/jupyter-core-5.3.0.ebuild
parentdev-python/jupyter_core: Remove old (diff)
downloadgentoo-6c690130a12b095ee0a9701dcc1749f27558da61.tar.gz
gentoo-6c690130a12b095ee0a9701dcc1749f27558da61.tar.bz2
gentoo-6c690130a12b095ee0a9701dcc1749f27558da61.zip
Rename dev-python/{jupyter_core → jupyter-core}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-core/jupyter-core-5.3.0.ebuild')
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/jupyter-core-5.3.0.ebuild b/dev-python/jupyter-core/jupyter-core-5.3.0.ebuild
new file mode 100644
index 000000000000..5d6b232808dc
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest