summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 07:56:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 08:21:51 +0200
commit3900e6f2244e545c211959ab7e89347640b9828c (patch)
tree38e16875f721f760fc0fb9b45ff5e284f86f53be /dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
parentRename dev-python/{jupyter_server_mathjax → jupyter-server-mathjax} (diff)
downloadgentoo-3900e6f2244e545c211959ab7e89347640b9828c.tar.gz
gentoo-3900e6f2244e545c211959ab7e89347640b9828c.tar.bz2
gentoo-3900e6f2244e545c211959ab7e89347640b9828c.zip
Rename dev-python/{jupyter_packaging → jupyter-packaging}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild')
-rw-r--r--dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild b/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
new file mode 100644
index 000000000000..d9c5608e9239
--- /dev/null
+++ b/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools to help build and install Jupyter Python packages"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter-packaging/
+ https://pypi.org/project/jupyter-packaging/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-60.2.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_build_api.py::test_build_package
+ tests/test_build_api.py::test_deprecated_metadata
+)