summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2018-05-28 10:07:31 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-29 10:00:21 +0200
commit23f0716f4e20cade8b38ee86c79896f137425b2f (patch)
tree4935d4e96e3a627dbc0a825650984ef11f127da4 /dev-python/jupyter_client/jupyter_client-5.2.3.ebuild
parentapp-crypt/codecrypt: drop old 1.7.5, 1.7.6 (diff)
downloadgentoo-23f0716f4e20cade8b38ee86c79896f137425b2f.tar.gz
gentoo-23f0716f4e20cade8b38ee86c79896f137425b2f.tar.bz2
gentoo-23f0716f4e20cade8b38ee86c79896f137425b2f.zip
dev-python/jupyter_client: Version bump to 5.2.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/8633
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-5.2.3.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild
new file mode 100644
index 000000000000..df80a23326e5
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ pytest --cov jupyter_client jupyter_client || die
+}