summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 21:15:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 21:22:32 +0100
commitab55bf3c80228d7533b67e8b6cf5269570825721 (patch)
tree6d62823843279e3f82f060aab1f3e73d05ad2c86 /dev-python/jupyter_client/jupyter_client-5.2.4.ebuild
parentdev-python/jupyter_client: Stabilize 5.2.3-r1 ALLARCHES (diff)
downloadgentoo-ab55bf3c80228d7533b67e8b6cf5269570825721.tar.gz
gentoo-ab55bf3c80228d7533b67e8b6cf5269570825721.tar.bz2
gentoo-ab55bf3c80228d7533b67e8b6cf5269570825721.zip
dev-python/jupyter_client: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-5.2.4.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.2.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.4.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.4.ebuild
deleted file mode 100644
index ce3429206f4a..000000000000
--- a/dev-python/jupyter_client/jupyter_client-5.2.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- )
- "
-
-python_test() {
- pytest -vv jupyter_client || die
-}