summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-09 09:56:21 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-09 10:19:32 +0200
commitbb0c286b97c297c35cd2af2be64fb2d66311a6de (patch)
tree82b44d90778e64f0834114685d76d2f78ece70a9 /dev-python/jupyter_client
parentwww-servers/tomcat: bump to 9.0.36 (diff)
downloadgentoo-bb0c286b97c297c35cd2af2be64fb2d66311a6de.tar.gz
gentoo-bb0c286b97c297c35cd2af2be64fb2d66311a6de.tar.bz2
gentoo-bb0c286b97c297c35cd2af2be64fb2d66311a6de.zip
dev-python/jupyter_client: Bump to 6.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index b6e486f6a939..52b8c5553cd6 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-5.2.3.tar.gz 271787 BLAKE2B 36761e53050874c141c38f545f8f6fb53c144c30f686b3706594d124a65e410c205379b7ecbeed12f1520f0f568c7db3c802223f6fdb8f76407074beacc21918 SHA512 89b980ecc281bc1512e1fc4ba35862cc6e541f825ee07a1382d300c8088f24611225ab415d6a7c1e4209c47a74c113ec95f863e8fb0b33c6db9eb9c3521fc0ae
DIST jupyter_client-5.3.4.tar.gz 275850 BLAKE2B a0884fb6cd2858b3ecf8353c6dc180370a53b4d59f77fdeb33c972c72857650e2e8b64ac5f6c9d223a99f30bb9ad9e06673cfe14b2d79abc0e4363104ffd15c3 SHA512 54b5206c08f5119feb50deb2d815d79a178799ad5c1231a0d03fc950ebbf6cb2f7c3a757024f788d416f808c57aa8476fcfa110f63182314bf2d5cdeb9a006cf
+DIST jupyter_client-6.1.3.tar.gz 290112 BLAKE2B 205d4fc4bee263b05a36c562db11fe9a0d39defa5d633e85412a7e6382ddc49f9875c5112c1d23108b8e8ae7e57060afebeef949d7bf685b9541dfd06ae43fcd SHA512 39756e1bd7a051092c70c5f75ff1a8b8dd308eb054b3e572d5682e832dc83e6935c3f845230908f1c3debe95977c7b7ae63c373aad4ea6c1e87674b083d5e72c
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.3.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.3.ebuild
new file mode 100644
index 000000000000..f637b4437ab2
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest