summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-31 08:36:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-31 08:38:01 +0200
commit545ae8944fe940a934a9d75f325309cca2b26963 (patch)
tree1c5cf41742cd9c6f308d45880ad922ae7e1c6cc5 /dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild
parentdev-ruby/plist: cleanup (diff)
downloadgentoo-545ae8944fe940a934a9d75f325309cca2b26963.tar.gz
gentoo-545ae8944fe940a934a9d75f325309cca2b26963.tar.bz2
gentoo-545ae8944fe940a934a9d75f325309cca2b26963.zip
dev-python/jupyter_console: Fix installing entry points
Closes: https://bugs.gentoo.org/734786 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild')
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild b/dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild
new file mode 100644
index 000000000000..a17d12565383
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ "
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+ "
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
+src_prepare() {
+ # use setuptools unconditionally
+ sed -i -e 's:distutils\.core:setuptools:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ script -eqc "nosetests -v" || die
+}