summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-09 09:17:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-09 10:41:49 +0200
commit4bc3afd5decb7e0e691b71600dc17089d9f1b0e5 (patch)
tree498941968fa687e31bdb3e3514921d9f1e12ce1e /dev-python/jupyter_core/jupyter_core-4.11.1.ebuild
parentdev-python/ipykernel: Bump to 6.15.1 (diff)
downloadgentoo-4bc3afd5decb7e0e691b71600dc17089d9f1b0e5.tar.gz
gentoo-4bc3afd5decb7e0e691b71600dc17089d9f1b0e5.tar.bz2
gentoo-4bc3afd5decb7e0e691b71600dc17089d9f1b0e5.zip
dev-python/jupyter_core: Bump to 4.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core/jupyter_core-4.11.1.ebuild')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.11.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.11.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.11.1.ebuild
new file mode 100644
index 000000000000..58d1fe82bb25
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest