summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-19 10:29:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-19 10:45:17 +0200
commit1eb0ba7d40a04f57153b7cbd39ffb5af7088d52a (patch)
treee6e297d8c2b4b81695195d57553a04e88099c2f0 /dev-python/jupyter_core
parentdev-python/pytools: Bump to 2022.1.4 (diff)
downloadgentoo-1eb0ba7d40a04f57153b7cbd39ffb5af7088d52a.tar.gz
gentoo-1eb0ba7d40a04f57153b7cbd39ffb5af7088d52a.tar.bz2
gentoo-1eb0ba7d40a04f57153b7cbd39ffb5af7088d52a.zip
dev-python/jupyter_core: Bump to 4.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.10.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index bfb25d5df68d..dc8f642adc82 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
+DIST jupyter_core-4.10.0.tar.gz 76535 BLAKE2B d224b39397fd1ee430a758b02f8c5f2116480f00b4f7c485ccbb71556522275f7aaedeaebebf7bbfb782e3fff4677b38d5d7d0ddb4d3a24b5741dccd2b43edcb SHA512 b11257aa6239d2cc51b63c4ae696b5e2862fd824f662875a9e2b663a84b86aec14aa21baae6e5c720155f2be37fd40925b913503e002401eee442d6d3258704d
DIST jupyter_core-4.9.2.tar.gz 74912 BLAKE2B 9a20e7982d1bda6a203f094aca6ebaa2b96d0482d728527b1b085b1242c94fb407d7f9da3e82c3e2af473c725bc7bebe701d493a201d8804c3d7aae9f80f9c11 SHA512 2779d7857b3efb979df29f65e5db0a625e4c96b1bbed017aa7bdaa7d23d7cb202d745c92db663a183bdcdc5f55133aa32bc6c982d5a9d36decceb9a348e7754b
diff --git a/dev-python/jupyter_core/jupyter_core-4.10.0.ebuild b/dev-python/jupyter_core/jupyter_core-4.10.0.ebuild
new file mode 100644
index 000000000000..3bc31c65bc0e
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest