summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-07 21:59:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-07 22:11:46 +0300
commit43d8d15718d91ab1a66d327998cb8a9e9585bf95 (patch)
tree9f42ba00a361ac500bd999c9ff1ccf65dd3a0d32 /dev-python/jupyter_core
parentdev-python/ansi2html: enable py3.11 (diff)
downloadgentoo-43d8d15718d91ab1a66d327998cb8a9e9585bf95.tar.gz
gentoo-43d8d15718d91ab1a66d327998cb8a9e9585bf95.tar.bz2
gentoo-43d8d15718d91ab1a66d327998cb8a9e9585bf95.zip
dev-python/jupyter_core: add 4.11.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.11.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index e95447b7063f..99fec7f4c64f 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.10.0.tar.gz 76535 BLAKE2B d224b39397fd1ee430a758b02f8c5f2116480f00b4f7c485ccbb71556522275f7aaedeaebebf7bbfb782e3fff4677b38d5d7d0ddb4d3a24b5741dccd2b43edcb SHA512 b11257aa6239d2cc51b63c4ae696b5e2862fd824f662875a9e2b663a84b86aec14aa21baae6e5c720155f2be37fd40925b913503e002401eee442d6d3258704d
+DIST jupyter_core-4.11.0.tar.gz 73671 BLAKE2B f7e8855428d77fb36728199f76299686ffe0db0738a537ce7a540dca0fd6605371a1fe9cc32cf890fa21d08895cc1249f3e10cb2491ee0ce94de9eaf6cad08ff SHA512 bdd328df8ba2f5792e3fca01b816ed8994e56886b3d260467c5fda63180552753d807383135b7f8a84274e8a16099eed3fa5a211948d6490a57a357bb3b55a71
diff --git a/dev-python/jupyter_core/jupyter_core-4.11.0.ebuild b/dev-python/jupyter_core/jupyter_core-4.11.0.ebuild
new file mode 100644
index 000000000000..58d1fe82bb25
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest